removed useless function name in debug messages since we use __FUNCTION__
3 lines of code changed in 1 file:
- remove device_name[] from struct _usbDevice
- use naming scheme usb:vendor/product
- simplify (a bit) the code
110 lines of code changed in 1 file:
remore *device_name[] argument from get_desc()
7 lines of code changed in 2 files:
add DEBUG_CRITICAL4
2 lines of code changed in 1 file:
set received size to 0 in case of error in CmdXfrBlockTPDU_T1
3 lines of code changed in 1 file:
in case of error exits CCID_Receive() without copying an nonexistent anwser
2 lines of code changed in 1 file:
use DEBUG_CRITICAL2() instead of DEBUG_CRITICAL()
1 lines of code changed in 1 file:
add the "Silitek SK-3105 keyboard" in the "Should work but untested by
me" list
1 lines of code changed in 1 file:
ignore some build files
0 lines of code changed in 4 files:
ignore some build files
2 lines of code changed in 2 files:
add Silitek SK-3105 keyboard
6 lines of code changed in 1 file:
add support of USB devices with multiple interfaces (like the Silitek
SK-3105 keyboard)
57 lines of code changed in 2 files:
add support of IFDHCreateChannelByName
110 lines of code changed in 6 files:
move rules for src/protocol_t1/ files in src/Makefile.am to avoid
building a (problematic) static library
25 lines of code changed in 1 file:
removed since rules for src/protocol_t1/ files are in src/Makefile.am
0 lines of code changed in 1 file:
define APDU_Cmd and APDU_Rsp
0 lines of code changed in 1 file:
new files from Carlos Prados towitoko-2.0.7 driver (with a bit of hacking)
946 lines of code changed in 11 files:
build protocol_t1 library
5 lines of code changed in 1 file:
add SetParameters() CCID command
37 lines of code changed in 1 file:
add support of T=1 in TPDU mode
14 lines of code changed in 1 file:
add CcidDesc.t1 field
15 lines of code changed in 1 file:
replace CmdXfrBlockTPDU() by CmdXfrBlockTPDU_T0() and CmdXfrBlockTPDU_T1()
66 lines of code changed in 2 files:
split CmdXfrBlockShortAPDU() in CCID_Transmit() and CCID_Receive()
26 lines of code changed in 1 file:
call ccid_open_hack() in IFDHCreateChannel() instead of in each OpenPort()
3 lines of code changed in 3 files:
use an (int *) instead of a PDWORD for rx_length argument
14 lines of code changed in 4 files:
new files. add definition of ACX_PTHREAD macro
31 lines of code changed in 2 files:
add get_ccid_slot() function
8 lines of code changed in 2 files:
remove function name from debug message since __FUNCTION__ is now used in
DEBUG_* macro definition
20 lines of code changed in 3 files:
add ActivCard
6 lines of code changed in 1 file:
created an "Should work but untested by me" section and add SCM Micro
SPR 532 and ActivCard USB reader 2.0
11 lines of code changed in 1 file:
The crashes under MacOS X were not because of a bug in libusb but because of
a bug in pcscd MacOS X hotplug.
0 lines of code changed in 1 file:
the USB extra field length shall be exactly 54 bytes to be CCID.
2 lines of code changed in 1 file:
also print the function name (__FUNCTION__) in the debug messages
17 lines of code changed in 1 file:
add a test on the USB extra field length to avoid a crash and print an
error message. This occurs when the reader is _not_ CCID and the CCID
driver is used (wrong Info.plist for example).
13 lines of code changed in 2 files: