Add the ability to parse all the configuration files of a directory
instead of just one configuration file.
update-reader.conf is then now obsolete.
See Debian bug #565896 http://bugs.debian.org/565896
66 lines of code changed in 7 files:
update copyright
1 lines of code changed in 1 file:
SCardEstablishContextTH() & SCardGetStatusChange(): completly initialize
structures sent to the daemon to avoid a valgrind warning:
Syscall param socketcall.send(msg) points to uninitialised byte(s)
2 lines of code changed in 1 file:
As of revision r4719 Linux is now Windows "compatible"
2 lines of code changed in 1 file:
" The gcc on Solaris 10 combined with the Sun loader appears to not
handle the gcc visibility attribute correctly. The sparc version says it
is ignored, the x86 version gives linker error. The attached patch
sun.gcc.1.5.6-svn-477.txt tries to test for gcc on Sun and not use the
visibility attribute. If on a sun and the compiler is not GCC, try and
use the Sun __global and __hidden instead. (I did not try the Sun Studio
compiler with this.) "
Thanks to Douglas E. Engert for the patch
http://archives.neohapsis.com/archives/dev/muscle/2010-q1/0127.html
5 lines of code changed in 1 file:
use @sysconfdir_exp@ instead of (removed) @confdir@
6 lines of code changed in 1 file:
RFStartSerialReaders(): typo in comment
1 lines of code changed in 1 file:
Fix 2 compilation warnings
configfile.c:1151: warning: �input� defined but not used
tokenparser.c:1167: warning: �input� defined but not used
2 lines of code changed in 2 files:
Fix splint error
src/pcsc-wirecheck-dist.c:19:164: Body of if clause of if statement is empty
4 lines of code changed in 1 file:
HPAddDevice(): fix a memory leak
2 lines of code changed in 1 file:
RFRemoveReader(): simplify/factorise the resources deallocation
3 lines of code changed in 1 file:
use @sysconfdir@ instead of (the now removed) @confdir@
Thanks to S�bastien Lorquet for the bug report
http://archives.neohapsis.com/archives/dev/muscle/2010-q1/0098.html
2 lines of code changed in 1 file:
use a dynamic instead of static allocation for lpcDevice
5 lines of code changed in 2 files:
RFAddReader(): allocate an int instead of a DWORD for pFeeds
The patch in revision 4741 was not complete
1 lines of code changed in 1 file:
In struct ReaderContext rename pdwMutex to pMutex and change type from
PDWORD to int *
20 lines of code changed in 2 files:
In struct ReaderContext rename pdwFeeds to pFeeds and change type from
PDWORD to int *
20 lines of code changed in 2 files:
In struct ReaderContext remove the now useless dwBlockStatus field
0 lines of code changed in 2 files:
In struct ReaderContext rename dwSlot to slot and change type from
DWORD to int
45 lines of code changed in 5 files:
In struct ReaderContext rename dwVersion to version and change type from
DWORD to int
37 lines of code changed in 4 files:
In struct ReaderContext change dwPort from DWORD to int and rename it to
port
Fix a compiler warning
readerfactory.c: In function �RFReCheckReaderConf�:
readerfactory.c:1393: warning: comparison between signed and unsigned
35 lines of code changed in 3 files:
Fix compiler warning
tokenparser.l: In function �tperrorCheck�:
tokenparser.l:102: warning: unused parameter �token_error�
1 lines of code changed in 1 file:
In struct SerialReader rename dwChannelId in channelId since it is an
int and no more a DWORD
8 lines of code changed in 3 files:
Fix a compiler warning
eventhandler.c: In function �EHStatusHandlerThread�:
eventhandler.c:494: warning: comparison between signed and unsigned
7 lines of code changed in 1 file:
do not use the uint32_t rv structure field but copy it into rv first to
avoid a compiler warning
winscard_clnt.c: In function ?SCardReconnect?:
winscard_clnt.c:1035: warning: comparison between signed and unsigned
winscard_clnt.c: In function ?SCardBeginTransaction?:
winscard_clnt.c:1254: warning: comparison between signed and unsigned
winscard_clnt.c: In function ?SCardStatus?:
winscard_clnt.c:1657: warning: comparison between signed and unsigned
winscard_clnt.c: In function ?SCardTransmit?:
winscard_clnt.c:2939: warning: comparison between signed and unsigned
12 lines of code changed in 1 file:
force the return codes SCARD_* to be long since the SCard* functions
return a LONG type
62 lines of code changed in 1 file:
In struct ReaderContext dwLockId is used to store a SCARDHANDLE so
change its type from DWORD to SCARDHANDLE and rename the field to hLockId
Fix 2 compiler warning:
winscard.c: In function 'SCardDisconnect':
winscard.c:847: warning: comparison between signed and unsigned
winscard_svc.c: In function 'MSGRemoveContext':
winscard_svc.c:807: warning: comparison between signed and unsigned
29 lines of code changed in 5 files:
fix a compilation warning
winscard_msg.c: In function �SHMMessageReceive�:
winscard_msg.c:252: warning: unused parameter �command�
2 lines of code changed in 1 file:
fix 2 compilation warnings
winscard_svc.c: In function �MSGRemoveContext�:
winscard_svc.c:776: warning: comparison between signed and unsigned
winscard_svc.c: In function �MSGAddHandle�:
winscard_svc.c:848: warning: comparison between signed and unsigned
2 lines of code changed in 1 file:
Use READER_STATE * instead of PREADER_STATE to make it explicit it
is a pointer
2 lines of code changed in 2 files:
Use READER_CONTEXT * instead of PREADER_CONTEXT to make it explicit it
is a pointer
77 lines of code changed in 8 files:
Fix a compilation warning
readerfactory.c: In function �RFAddReaderHandle�:
readerfactory.c:1125: warning: comparison between signed and unsigned
1 lines of code changed in 1 file:
In struct ReaderContext rename "dwContexts" to "contexts" since it is no
more a DWORD but a int32_t
32 lines of code changed in 4 files:
Fix a compilation warning
winscard_clnt.c: In function �SCardListReaderGroups�:
winscard_clnt.c:3258: warning: comparison between signed and unsigned
1 lines of code changed in 1 file:
Use dynamic instead of static allocation for the driver library
filename. The filename is no more limited to 100 characters.
Closes: [#312332] MAX_LIBNAME too short?
6 lines of code changed in 3 files:
use int instead of unsigned int for customMaxThreadCounter,
customMaxReaderHandles and customMaxThreadCardHandles since list_size()
returns an int and we compare the two values (avoid sign mismatch)
5 lines of code changed in 3 files:
fix 2 compilation warnings
winscard_svc.c: In function �CreateContextThread�:
winscard_svc.c:146: warning: comparison between signed and unsigned
winscard_svc.c: In function �MSGAddHandle�:
winscard_svc.c:856: warning: comparison between signed and unsigned
2 lines of code changed in 1 file:
SCardGetStatusChange(): fix 4 compilation warnings
winscard_clnt.c: In function �SCardGetStatusChange�:
winscard_clnt.c:1864: warning: comparison between signed and unsigned
winscard_clnt.c:1875: warning: comparison between signed and unsigned
winscard_clnt.c:1911: warning: comparison between signed and unsigned
winscard_clnt.c:2189: warning: comparison between signed and unsigned
1 lines of code changed in 1 file:
Make SCardReconnect(), SCardStatus() and SCardTransmit() block instead
of returning SCARD_E_SHARING_VIOLATION immediately. These functions will
then behave like on Windows.
This can happen if these functions are called when the reader is locked
by a PCSC transaction (SCardBeginTransaction/SCardEndTransaction).
You can define the environment variable PCSCLITE_NO_BLOCKING to use the
old behavior.
Thanks to Jean-Luc Giraud for the patch.
http://archives.neohapsis.com/archives/dev/muscle/2010-q1/0041.html
37 lines of code changed in 1 file:
add a command parameter to SHMMessageReceive() to be able log the
ongoing command in case of problem
28 lines of code changed in 4 files:
Check the return value of SCardConnect() on a reader already used in
SCARD_SHARE_EXCLUSIVE mode
94 lines of code changed in 1 file:
fix a bug introduced by the previous revision
2 lines of code changed in 1 file:
SCardGetAttrib(): check for buffer overflow with
SCARD_ATTR_DEVICE_FRIENDLY_NAME
Thanks to Jean-Luc Giraud for complete SCARD_ATTR_DEVICE_FRIENDLY_NAME
patch
11 lines of code changed in 1 file:
add a copyright for Martin Paljak
4 lines of code changed in 2 files:
Use the standard --sysconfdir=DIR ($prefix/etc by default) instead of
--enable-confdir=DIR for defining the directory containing reader.conf
2 lines of code changed in 2 files:
sysconfdir_exp is a configuration directory not configuration file
1 lines of code changed in 1 file:
SCardStatus(): returns SCARD_E_SHARING_VIOLATION if the reader is
already used
More conform to Windows
6 lines of code changed in 1 file:
allow to use any reader and not just the first one
9 lines of code changed in 1 file:
test SCARD_ATTR_DEVICE_FRIENDLY_NAME
30 lines of code changed in 1 file:
SCardGetAttrib(): add support of SCARD_ATTR_DEVICE_FRIENDLY_NAME as it
is better implemented in pcscd (it knows the friendly name)
14 lines of code changed in 1 file:
SCardEstablishContext(): set PCSCLITE_PCSCD_ARGS with the argument you
want to pass to pcscd in autostart
Only one argument is passed. The space character is not a separator.
example: export PCSCLITE_PCSCD_ARGS=-dfa
3 lines of code changed in 1 file:
pcscd will suicide itself after 60 seconds of inactivity if it is
started using --auto-exit
This is the default behavior when pcscd is started by libpcsclite
31 lines of code changed in 4 files:
do not ignore the SIGALRM signal any more since we need it for the auto
exit feature
0 lines of code changed in 1 file: